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The Desktop Cl ient Inter face

Introduction

Unlike a conventional item of hi-fi equipment, the HDX can be operated in a number 
of different ways using a variety of user interfaces. The user interface you use to 
control your HDX will depend on the type of system in which it is installed and the 
ancillary equipment available.

If the HDX is installed in a home network that includes a personal computer running 
Windows XP, Windows Vista or Windows 7, it can be operated via the Desktop 
Client Interface. The Desktop Client application provides the most comprehensive 
operational and search functionality. The Desktop Client is covered in the following 
pages.

1 The Desktop Cl ient Interface

The HDX Desktop Client is an application that can be 
installed on a PC running Microsoft Windows XP or Windows 
Vista or Windows 7. The PC must be connected to the 
network that incorporates the HDX. The application and its 
installer can be found on the CD packed with the HDX.

In addition to enabling control of HDX music playback, 
the Desktop Client interface also provides a variety of HDX 
setup and maintenance functions that are not available 
from any other interface.

To install the Desktop Client application insert the CD into 
the PC’s CD drive, double click on the Desktop Client icon 
and follow the on-screen prompts. Ensure that the HDX 
is switched on and connected to the network when the 
Desktop Client application is run.

The format of the Desktop Client interface and its operation 
will be familiar to those with experience of the Windows 
Explorer file browser application.

1.1 Connecting to The HDX

When first run, the Desktop Client application will scan the 

network to identify any connected Naim hard disk players. 

A window will open, illustrated below, listing the player or 

servers found and their IP addresses. Each player “name” 

listed is a shortened form of the MAC address printed on its 

rear panel.

If the Desktop Client has been previously connected to 

other network items (or to items with variable IP addresses) 

these may also be listed. Use the shortened MAC address 

shown in the name column to identify the HDX.

If the HDX is not immediately listed, check that it is 

connected to the network and switched on, and click on 

Scan for hard disk players.

Note: It can take as long as a minute for the HDX to “boot-

up” and become visible to the Desktop Client.

Select the Name that refers to the appropriate hard disk 

player by clicking on it, and click OK. The selected hard 

disk player will now be connected to the Desktop Client.
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1.2 The Interface Screen

All Desktop Client functions are controlled via one main 

window. The window comprises a number of separate 

areas and tools distinguished by their application and 

context. The windows and tools are identified in Diagram 
1.3 and described in the following paragraphs.

1.3 Interface Windows and Elements

Transport controls (Section 1.4) 

Application menus (Section 1.5)

Now playing (Section 1.6)

Interface tabs (Section 1.7)
Simple Search (Section 1.10)

Music library

Music library file detail

1.4 Transport  Controls

As well as providing stop, play/pause, fast forward, fast 
reverse, step forward and step reverse, the transport 

controls also include shuffle, repeat and rip mode buttons. 

The rip mode button switches the HDX between Rip and 

Playback modes. In Rip mode the HDX will automatically 

rip a CD inserted in its drawer. In Playback mode the HDX 

will automatically play a CD inserted in its drawer through 

its local audio outputs.

The shuffle function is applied to the current playlist while 

the repeat function can be applied to either single tracks 

or the current playlist. For more on creating and managing 

playlists see Section 1.13.

1.5 Application Menus

The application menus comprising File, Edit, Action, View 

and Help provide a variety of tools and functions. They are 

described in the following paragraphs.

1.5.1 The File Menu

The File Menu provides network Connect and Disconnect 
commands, and application Exit command.

1.5.2 The Edit Menu

The Edit Menu provides file utilities (rename, etc.), copy 

and paste functions, select functions and access to file 

properties. 

1.5.3 The Actions Menu

The Actions Menu provides alternative access to play, 

queue and random play functions.

1.5.4 The View Menu

The View Menu enables selection of alternative interface 

views:

Player Mode view in which only the Transport Controls, 

Currently Playing Data and Application Menus are 

displayed.

Maintenance Mode view in which only the Music Library 

data and Music Library detail windows are displayed. 

Interrogation of the maintenance screens does not affect 

the track or playlist currently playing. 

Player and Maintenance view in which both modes are 

displayed. Diagram 1.3 shows the Player and Maintenance 

view.

1.5.5 The Help Menu

The Help Menu provides Desktop Client Application 

installation and version information.

1.6 Now Playing

The Now Playing field displays the artist, album, title and 

genre of the track currently playing.

Advanced Search (Section 1.10)
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1.7 Interface Tabs

The Interface Tabs serve to select one of three interface 

maintenance pages: Music Library, Tools and Now Playing.

1.7.1 The Music Library Tab

The Music Library tab selects the page illustrated in 

Diagram 1.3. The external storage hardware items to which 

the interface is connected (if any, beyond the HDX’s 

internal storage) are listed in the left hand window. They 

can be selected and their contents expanded by clicking 

on their associated + graphics. The display in the right 

hand window will then show the detail of music files stored 

on each hardware item. Clicking on the column headings 

will re-order the list of items sorted by the heading criteria.

1.7.2 The Tools Tab

The Tools tab selects the interface page illustrated 

in Diagram 1.8. It provides a set of hard disk player 

maintenance and setup utilities, listed in the left hand 

window, that can be selected and their contents 

expanded by clicking on their associated + graphics. 

Selecting a utility will open a dialogue box in the right 

hand window that either provides information, or can be 

used to specify a variety of hard disk player and network 

setup parameters.

Diagram 1.8 illustrates the Tools tab with the utilities in the 

left hand window and displays the Ripping Monitor utility 

in the right hand window. The full list of tools and utilities is 

described in Section 1.18.

1.8 Interface Tabs - Tools

1.7.3 The Now Playing Tab

The Now Playing tab 

selects the interface page 

illustrated in Diagram 1.9. 

The page displays the 

track currently playing, its 

associated information 

and the playlist in which it 

is included. 

The page also includes 

a text entry field for 

naming playlists and 

buttons for saving, 

shuffling (randomising) 

and clearing playlists. For 

more about creating and 

managing playlists see 

Section 1.13.

 1.9 Interface Tabs - Now Playing
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1.10 Simple and Advanced Search

The search tools of the Music Library page enable music 

files to be located for immediate playback or for addition 

to a playlist.

The Search tools illustrated in Diagram 1.11 enables 

searches to be carried out of either albums and artists or 

individual tracks. It is not necessary to type a full name or 

title in the search entry field although the more detail that 

is entered, the more fruitful a search is likely to be.

After entering the search text in the entry field and 

selecting either Albums/Artists or Tracks Only click on the 

Go button to initiate the search. The search results will 

be listed in the right hand Music Library page 

window. Double click on an item to play it 

immediately.

The Advanced Search tool enables a finely 

targeted search of music files to be performed. 

To begin an advanced search click on the 

Advanced Search button. A text entry window 

will open as illustrated in Diagram 1.12.

The advanced search text entry window 

enables two sets of search rules that can be 

configured to search for an album, artist, track, 

genre, composer, performer or conductor. 
Each rule can also be constrained to contain, 

begin with, match exactly, not contain or not 
match exactly the search text.

A search can also be constrained to match 

all or any of the search rules and carefully configuring the 

search rules should enable any specific music file to be 

found quickly.

For example, if a music library contained numerous 

Beethoven symphonies, but only versions conducted by 

Leonard Bernstein were required for playback, a search 

set up as illustrated in Diagram 1.12 would quickly find the 

appropriate music.

 1.11 Simple Search

 1.12 Advanced Search
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1.13 Playl ists

A playlist is a list of tracks arranged in a queue for 

playback. A playlist may be defined by the running order 

of an album, by selecting specific tracks or albums or be 

created by selecting tracks with the same, artist, genre, 

composer, conductor or performer. Playlists can be named 

and saved for later use.

To create, name and save a track playlist proceed as 

follows:

• �Click on the Music Library Interface Tab and then on 

the + graphic adjacent to the Albums thumbnail to 

expand the list of albums available to the server.

• �Select the album on which the first track required in 

the playlist resides and then select that track in the 

right hand window. Go to the application Actions 

menu and select Queue. Alternatively “right click” on 

the album and select Queue in the pop-up list.

• �Repeat the selection and queuing of tracks until the 

desired playlist is complete.

• �Click on the Now Playing Interface Tab. The queue 

of selected tracks will be displayed in the main 

window. To save the playlist, name it in the text entry 

field and click on 

Save. The playlist 

can be shuffled 

(randomised) or 

cleared by clicking 

on the appropriate 

buttons. Diagram 
1.14 illustrates 

saving a playlist.

Note: Clearing the current 

playlist does not delete 

tracks from the music 

library, it just removes 

them from the queue.

• �Once saved, the playlist can be recalled from the 

Music Library Interface Tab. Click on the + graphic 

adjacent to the Playlists thumbnail to expand the list 

of saved playlists then select the desired one. To play 

the playlist go to the application Actions menu and 

select Play.

 1.14 Save Playl ist
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1.15 Album Propert ies

The Desktop Client Application holds more information 

about specific albums than is displayed in the Player Mode 

or Maintenance Mode views. The information can be 

displayed by selecting the album’s properties. To access 

an album’s properties first right-click on the album name. 

A pop-up window will display as illustrated in Diagram 1.16. 

Note: As well as providing 

access to properties the 

right-click pop-up menu 

also provides access to a 

variety of other functions.

Clicking on properties 

displays the additional 

information for the album 

concerned as illustrated 

in Diagram 1.17.

 1.16 Selecting Album Propert ies

 1.17 Displaying Album Propert ies
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1.18 Tools and Ut i l i t ies

The Tools tab provides a set of hard disk player 

maintenance and setup utilities that can be selected and 

their contents expanded by clicking on their associated 

+ graphics. Selecting a utility will open a dialogue box in 

the right hand window that either provides information, or 

can be used to specify a variety of hard disk player and 

network setup parameters. The purpose and use of each 

tool and utility is described in the following paragraphs. 

Diagram 1.19 illustrates the full list of tools and utilities.

1.18.1 Ripping Monitor
Display real-time progress of CD ripping.

1.18.2 Ripping Alerts
Displays the server’s ripping log including any alerts.

1.18.3 Zone Maintenance
Enables network zone definition and maintenance.

1.18.4 Move Album Monitor
Displays real-time progress of album move operations 

between storage locations.

1.18.5 Backup Monitor
Displays backup statistics and enables backup settings to 

be defined.

1.18.6 Backup Scheduler
Enables manual backups to be initiated and automatic 

backups to be programmed.

1.18.7 System Status
Displays various system status reports.

1.18.8 System Messages
Displays any system messages.

1.18.9 Lookup Messages
Displays any CD data lookup messages.

1.18.10 System Settings
Displays and enables editing of various system settings.

Note: The HDX internal clock and calender can be 

adjusted here.

1.18.11 System Functions
Provides image purge, database rebuild functions and 

version info. Only use if instructed to do so by Naim 

Technical Support.

1.18.12 Recycle Bin
Enables items within the recycle bin to be either purged or 

restored to the library.

1.19 Tools and Ut i l i t ies

1.18.13 USB Devices
Displays a list of current or previously connected USB 

devices.

1.18.14 Scanable Network Shares
Displays a list of current or previously connected network 

devices.

1.18.15 Stores For Ripped Music
Displays a list of currently enabled Music Stores and their 

order of priority. 
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